techmicrobio.eu
site destiné aux STL-Biotechnologies et aux BTS/DUT biologiques

Recherche

Text Size

Nous avons 73 invités et aucun membre en ligne

Conclure une numération en milieu liquide par le NPP (MPN)

Présentation

Se reporter aux pages 197 à 195 de Microbiologie alimentaire pour la présentation du NPP (méthode de Mac Grady).
La solution adoptée ici, pour un usage et des raisons pédagogiques, est une feuille de tableur (excel). Il est probable que des imperfections ou des erreurs subsistent que vous pourrez signaler en cliquant ici.
Pour télécharger la feuille : cliquer ici.

Technique

Les précisions concernent les formules utilisées.
Il est un bon exercice de tenter de refaire la feuille soi-même pour comprendre le fonctionnement du tableur. On pourra donc s'aider de la solution proposée, l'améliorer… ou même en trouver une meilleure qui pourra être publiée sur le site si vous le souhaitez (à votre nom bien sûr).
L'affichage utilise les formats conditionnels.
Quelques indications sur les formules utilisées :

  • en B12 et B13, la formule calcule les dilutions suivants celle qui est introduite. On peut rajouter des vérifications.
  • en B18, la formule fabrique la chaine de chiffres pour test (=CONCATENER(C11;C12;C13)).
  • en B19, la formule recherche dans la table la valeur correspondant au nombre précédent (=RECHERCHEV(C18;C35:F74;2)). En B20, et B21, la même démarche permet de trouver les bornes inférieure et supérieure.
  • en D23, la formule calcule la concentration (=volume_par_tube*npp*10^-dilution_initiale). Même démarche pour les bornes. (les références nommées sont en B15 et B11.
  • en C26, la formule affiche le résultat en tenant compte des bornes du tableau (=SI(C18="000";CONCATENER("moins de ";0,3*10^-dilution_initiale*volume_par_tube);SI(C18="333";CONCATENER("plus de ";100*10^-dilution_initiale*volume_par_tube);D23))).
  • en C27 et C28, les formules affichent avec les bornes.

Cette version ne tient pas compte de la catégorie définie dans la dernière colonne.
Une autre version sera disponible prochainement grâce au travail de Fabien CÉZARD.

________________________________________
Date de mise à jour : 9 février 2011